Fulqrum Publishing Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official Fulqrum Publishing forum > Fulqrum Publishing > IL-2 Sturmovik > Daidalos Team discussions

Reply
 
Thread Tools Display Modes
  #1  
Old 09-06-2023, 09:21 AM
papote papote is offline
Approved Member
 
Join Date: Jul 2015
Posts: 20
Default please help with il2-46 upgrade

i purchased the COG version of IL2 46 and their version goes only to 4.13.4
and i want to upgrade to latest version
so, reading the instructions i have to first patch my 4.13.4 to 4.14.1

I downloaded:

Patch from 4.13.4 to 4.14.1
https://gtac-sim.fr/patch/IL2_414_4141_MULTI.exe
https://gtac-sim.fr/patch/IL2_414_4141_MULTI-1.bin

I opened IL2_414_4141_MULTI.exe
and started the patching process, the installation program asked me to select my game folder and so i did. i pressed install and it did its thing. But when i open the game it is still in 4.13.4 what am I missing?
Reply With Quote
  #2  
Old 09-06-2023, 10:54 AM
JacksonsGhost JacksonsGhost is offline
Approved Member
 
Join Date: Oct 2015
Location: Australia
Posts: 177
Default

Quote:
Originally Posted by papote View Post
i purchased the COG version of IL2 46 and their version goes only to 4.13.4
and i want to upgrade to latest version
so, reading the instructions i have to first patch my 4.13.4 to 4.14.1

I downloaded:

Patch from 4.13.4 to 4.14.1
https://gtac-sim.fr/patch/IL2_414_4141_MULTI.exe
https://gtac-sim.fr/patch/IL2_414_4141_MULTI-1.bin

I opened IL2_414_4141_MULTI.exe
and started the patching process, the installation program asked me to select my game folder and so i did. i pressed install and it did its thing. But when i open the game it is still in 4.13.4 what am I missing?
Firstly, I think you mean the GOG version. I have never used the GOG or Steam versions, but I remember a Steam user claimed the 4.13.4 to 4.14.1 patch broke the Steam version for them. Maybe GOG is the same.

His fix was to load the 4.14 patch first, then the 4.14.1 patch separately. He said that worked fine.

In any case, when installing the 4.14 patch, make sure you have the exe and the bin file in the same folder (any folder) when you run the exe, and direct the install to the folder where your 4.13.4 files are.

Also make sure you back up any third party programs you may have attached, because the anti-cheater element of the 4.14 installer can delete them. In fact a complete backup of your install is a great idea if you can do it.

Let us know how you go. The 4.14 and 4.15 patches can be difficult. If you have further problems please ask.
Reply With Quote
  #3  
Old 09-07-2023, 07:36 AM
papote papote is offline
Approved Member
 
Join Date: Jul 2015
Posts: 20
Default thanks for the reply friend

when you say : direct the install to the folder where your 4.13.4 files are;

you mean the root directory of the game right?

one question though, im looking at all these mods available for the game
and theres so many it makes my head spin. the question is: should i upgrade the game to 4.15 or should i just downgrade to 4.12 and install VP modpack
or the BAT mod.... ?

thank you
Reply With Quote
  #4  
Old 09-07-2023, 09:00 AM
papote papote is offline
Approved Member
 
Join Date: Jul 2015
Posts: 20
Default thanks for the reply friend

when you say : direct the install to the folder where your 4.13.4 files are;

you mean the root directory of the game right?

one question though, im looking at all these mods available for the game
and theres so many it makes my head spin. the question is: should i upgrade the game to 4.15 or should i just downgrade to 4.12 and install VP modpack
or the BAT mod.... ?

thank you
Reply With Quote
  #5  
Old 09-07-2023, 04:37 PM
JacksonsGhost JacksonsGhost is offline
Approved Member
 
Join Date: Oct 2015
Location: Australia
Posts: 177
Default

Quote:
Originally Posted by papote View Post
when you say : direct the install to the folder where your 4.13.4 files are;

you mean the root directory of the game right?

one question though, im looking at all these mods available for the game
and theres so many it makes my head spin. the question is: should i upgrade the game to 4.15 or should i just downgrade to 4.12 and install VP modpack
or the BAT mod.... ?

thank you
Yes, browse to the root directory of the game for install.

As for which branch of the game to take, if you ask 10 members of the community, you will probably get 10 different answers . Most people have multiple installs, but I don't know if that works in GOG/Steam.

If you want to use mod packs, most of them are based on 4.12.2, or Y-Pack is 4.13.4. You can still install isolated mods even in 4.15.1, but most of the mods are not made for it, so it is a bit hit and miss. Many keep a clean install of 4.12.2 or earlier in case they want to build a new install at any time.

I'm mostly just a stock 4.15.1 gamer, but this thread from Mission4Today gives some good discussion on the pros and cons of various mod options, depending on what you want to do:

https://www.mission4today.com/index....wtopic&t=25646
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:27 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Copyright © 2007 Fulqrum Publishing. All rights reserved.