PDA

View Full Version : 4.11: AI Waypoint Issues


Aviar
02-18-2012, 10:35 AM
I've been using the FMB quite a bit in 4.11. I've been building new missions as well as converting some of my original coops to use some of the new 4.11 features.

However, I have noticed several issues with the AI waypoints. I'm only going to point out one for now because it's the easiest to prove.

Some of my favorite older missions are low-level bomber strikes. Generally, they seem to work ok in 4.11. Unfortunately, some of them don't.

The ones that don't work are very low-level bombers that are following deep valleys, river gorges or narrow Norway fjords.

In 4.10 and earlier, these missions worked perfectly. In 4.11, the bombers are having a tough time following their waypoints. Many times they totally miss their waypoints and after that everything just falls apart. Planes start circling, searching for a waypoint....crashing into terrain and generally ruining the entire mission.

I believe that I read somewhere that the AI in 4.11 now has a better detection of hills/mountains. My guess is that this new 'awareness' of terrain is creating an issue with low-level waypoints (and nearby elevated terrain). That's just a guess, of course. It could be something totally different.

My main point is that these cool missions are no longer playable. I'm attaching my 'Telgart' coop mission that I have hosted many times. I've had people tell me it's their favorite mission. However, the bombers won't follow their waypoints anymore and simply scatter in all directions.

I have stripped the mission of all enemy planes, escorts and AAA so it is easier to test. All I have are the low-level bombers and their waypoints. They are supposed to follow a river gorge until they they reach a secret complex and then bomb the buildings. It no longer works in 4.11.

To test it, load it into the FMB and click on play. You will be in the lead bomber, so just activate the autopilot as soon as the mission starts. Bring up the map and see the zig-zagging waypoints the bombers are supposed to fly as they follow the river gorge at low level.

You will quickly see that everything goes bad as soon as the flights enter the gorge at waypoint 2. None of the flights head for waypoint 3. They go straight for a while and then scatter. After that the mission is basically worthless. If you play the same mission in 4.10 or earlier, it works perfectly. The bombers follow all of their waypoints. I can't remember a plane ever missing a single waypoint.

I have another mission I created years ago where low-level bombers cruise down a narrow fjord on the Norway map. It's a very unique mission and another favorite of mine. This week I realized it won't work anymore in 4.11. I tried for 2 days to remake the mission but I finally realized that the new AI just won't allow for certain kinds of low-level activity.

I really feel bad having to point out some of these issues in 4.11 because I really like the new patch and I want it to be accepted. However, if I don't, eventually others will find them anyway and we may as well inform DT as soon as possible. I understand that some of these issues may not be resolved....that happens.

I have found some other waypoint issues but I don't want to overwhelm DT with too many problems at once. If I decide to, I'll address those at a later date.

Basically, I'm posting the mission here so my fellow mission creators are aware of the issue.

Aviar

FC99
02-18-2012, 12:52 PM
I believe that I read somewhere that the AI in 4.11 now has a better detection of hills/mountains. My guess is that this new 'awareness' of terrain is creating an issue with low-level waypoints (and nearby elevated terrain). That's just a guess, of course. It could be something totally different.
You guessed right, I'll see what can be done about this.

I really feel bad having to point out some of these issues in 4.11 because I really like the new patch and I want it to be accepted.

Don't feel bad, your reports are invaluable and they are perfect example how to report the problem and actively help the solution.

I have found some other waypoint issues but I don't want to overwhelm DT with too many problems at once.
Post everything you have, we might be able to squeeze the solution into 4.11.1