PDA

View Full Version : please help


papote
11-21-2023, 05:42 AM
i bought IL2 46 a while back from GOG.
and i enjoy it just as much as i did back when it was released all those years ago.

my issue is with the graphics. first of all i use to run this game in perfect back in the day so i know about open gl and settings in the config file.

the thing is that for the life of me i can not set this game on perfect.
if i set it on perfect the game does not run right and the water shows as this solid dark blue texture. im in windows 11. maybe is dirext x issue?
or is it this GOG version? by the way i have upgraded the game to 4.15.1

JacksonsGhost
11-22-2023, 06:16 AM
Don't give up too easily. It can probably be fixed.

I'm running 4.15.1 on Windows 11 with Nvidia GTX 1650 and 12th Gen Intel i5. Perfect mode (for Landscape Detail) works fine running OpenGL.

If you are running OpenGL, and none of the fixes in the other thread you posted to are working for you, please post your config.ini, and someone might be able to see where your problem lies.

If you are not running OpenGL, try it.

papote
11-22-2023, 09:51 AM
Here is my config i know HardwareShaders=0
but if i set it to =1 , in game settings say im in perfect but the game runs
not smooth and the water looks like its a solid dark blue texture


[il2]
title=Il2-Sturmovik 1946
hotkeys=HotKey game

[window]
width=1920
height=1080
ColourBits=32
DepthBits=24
StencilBits=8
ChangeScreenRes=1
FullScreen=1
DrawIfNotFocused=0
EnableResize=0
EnableClose=1
SaveAspect=0
Use3Renders=0
WideScreenFoV=1
UIColor=0
UIDetail=0
UIBackground=rnd
Use3RendersUI=0
FastDetectBit=32
FastDetectMode=2

[GLPROVIDER]
GL=Opengl32.dll

[GLPROVIDERS]
Open GL=Opengl32.dll
DirectX=dx8wrap.dll

[NET]
speed=25000
routeChannels=0
serverChannels=31
localPort=21000
remotePort=21000
SkinDownload=1
serverName=No Name
serverDescription=
remoteHost=
localHost=
socksHost=
checkServerTimeSpeed=1
checkClientTimeSpeed=0
disableNetStatStatistics=0
showPilotNumber=1
showPilotPing=1
showPilotName=1
showPilotScore=1
showTeamScore=0
cumulativeTeamScore=0
showPilotArmy=1
showPilotACDesignation=1
showPilotACType=1
filterUserNames=1
reflyKIADelay=0
maxAllowedKIA=-1
reflyKIADelayMultiplier=0.0
reflyDisabled=0
allowMorseAsText=1
allowCustomSounds=0
remoteHost_000=:21000

[MaxLag]
farMaxLagTime=10.0
nearMaxLagTime=2.0
cheaterWarningDelay=5.0
cheaterWarningNum=-1

[chat]
region=(dx=0.6925,dy=0.071666665,x=0.0,y=0.0)

[game]
Arcade=0
HighGore=1
mapPadX=0.99930555
mapPadY=-0.02962963
viewSet=37
Intro=0
NoSubTitles=0
NoChatter=0
NoHudLog=0
NoLensFlare=0
iconTypes=3
eventlog=eventlog.lst
eventlogkeep=0
3dgunners=1
ScreenshotType=1
RecordingIndicator=0
MapAlpha=0.99
SaveTrk=1
SkipParatrooperViews=0
NoMissionInfoHud=0
noKillInfoHud=0
BlockMorseChat=0
SmallMapWPLabels=1
ShowMorseAsText=0
IconUnits=1
lowInfoHud=0
Mouse6DOFMove=0
DebugFM=0
DebugCustomization=0
selectMirror1=3
selectMirror2=7
MaxVisualDistance=5000.0
MaxStaticVisualDistance=4000.0
MaxLongVisualDistance=10000.0
MaxPlateVisualDistance=16000.0


[HotKey game]
PrintScreen=ScreenShot
P=pause
Pause=pause

[HotKey gui]
Escape=activate

[HookViewFly Config]
timeFirstStep=2.0
deltaZ=10.0

[HookView]
MouseLeft=Len

[HookView Config]
AzimutSpeed=0.1
TangageSpeed=0.1
LenSpeed=1.0
MinLen=1.0
DefaultLen=20.0
MaxLen=3000.0
Speed=6
LeanF=0.2
LeanS=0.48
Raise=0.96999997
RubberBand=1.0

[HotKey builder]
MouseLeft=objectMove
MouseRight=popupmenu
Enter=freeView
Shift MouseLeft=worldZoom
Alt MouseLeft=select+
Alt MouseRight=select-
Alt Ctrl=unselect
PageDown=change+
PageUp=change-
End=change++
Home=change--
Ctrl MouseLeft=insert+
Insert=insert+
NumPad-0=insert+
F=fill
Ctrl MouseRight=delete+
NumPad.=delete+
Delete=delete+
Backspace=cursor
Tab=cursor
F10=land
F11=onLand
NumPad-=normalLand
NumPad+=toLand
NumPad-5=resetAngles
NumPad-8=resetTangage90
NumPad-7=stepAzimut-5
NumPad-4=stepAzimut-15
NumPad-1=stepAzimut-30
NumPad-9=stepAzimut5
NumPad-6=stepAzimut15
NumPad-3=stepAzimut30

[MouseXYZ]
F1=SpeedSlow
F2=SpeedNormal
F3=SpeedFast
MouseRight=XYmove
F4 MouseRight=Zmove
MouseMiddle=Amove
F5 MouseRight=Amove
F6 MouseRight=Tmove
F7 MouseRight=Kmove

[MouseXYZ Config]
RealTime=1

[HotKey Console]
Shift Tab=Activate
[Console]
HISTORY=1024
HISTORYCMD=1024
LOAD=console.cmd
SAVE=console.cmd
LOG=0
LOGTIME=0
LOGFILE=log.lst
LOGKEEP=0
LOGDEBUG=0
LOGBUFFER=2048
UseStartLog=0

[sound]
SoundUse=1
SoundEngine=1
Speakers=0
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=3
ObjectVolume=14
MusState.takeoff=1
MusState.inflight=1
MusState.crash=1
MusFlags.play=0
MasterVolume=14
Attenuation=7
SoundMode=1
SamplingRate=2
NumChannels=2
SoundExt.occlusions=0
SoundFlags.hardware=1
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=0
SoundExt.volumefx=0
SoundFlags.voicemgr=0
SoundFlags.static=1
VoiceVolume=4
Channels=2
SoundExt.extrender=0
SoundFlags.bugscorrect=0
SoundSetupId=8
ActivationLevel=0.02
Preemphasis=0.85
RadioLatency=0.5
AGC=1
PTTMode=1
SoundFlags.UseRadioChatter=0
SoundFlags.AutoActivation=0
RadioFlags.PTTMode=0
RadioFlags.PlayClicks=0
ActLevel=0
MicLevel=0
SoundFlags.forceEAX1=0
DebugSounds=0

[rts]
;ProcessAffinityMask=0
mouseUse=2
joyUse=1
trackIRUse=1
DisableIME=0
locale=us
UseSmartAxis=0
JoyProfile=0
joyTick=100

[rts_mouse]
SensitivityX=1.0
SensitivityY=1.0
Invert=0
SensitivityZ=1.0

[rts_joystick]
X=0 1 4 9 16 25 36 49 64 81 100 0
Y=0 1 4 9 16 25 36 49 64 81 100 0
Z=0 10 20 30 40 50 60 70 80 90 100
RZ=0 10 20 30 40 50 60 70 80 90 100 0
FF=1
U=0 10 20 30 40 50 60 70 80 90 100 0
V=0 10 20 30 40 50 60 70 80 90 100 0
1X=0 22 19 23 31 40 51 62 74 85 100 0 0
1Y=0 21 19 23 31 40 51 62 74 85 100 0 0
1RZ=0 17 15 21 27 40 51 62 74 85 100 0 0
1U=0 100 100 100 100 100 100 100 100 100 100 50 0
1V=0 100 100 100 100 100 100 100 100 100 100 0 0
1X1=0 100 100 100 100 100 100 100 100 100 100 0 0
1Y1=0 100 100 100 100 100 100 100 100 100 100 0 0
1Z1=0 100 100 100 100 100 100 100 100 100 100 10 0
1RZ1=0 100 100 100 100 100 100 100 100 100 100 0 0
1X2=0 100 100 100 100 100 100 100 100 100 100 0 0
1Y2=0 100 100 100 100 100 100 100 100 100 100 0 0
1Z2=0 100 100 100 100 100 100 100 100 100 100 0 0
1Z=0 100 100 100 100 100 100 100 100 100 100 0 0
1U1=0 100 100 100 100 100 100 100 100 100 100 0 0
1V1=0 100 100 100 100 100 100 100 100 100 100 0 0

[Render_DirectX]
TexQual=3
TexMipFilter=3
TexCompress=0
TexFlags.UseDither=0
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=0
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=0

HardwareShaders=0

Shadows=1
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=0
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=15
Water=2
Effects=1
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

[Render_OpenGL]
TexQual=3
TexMipFilter=3
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.DepthClampNV=1
TexFlags.TexEnvCombine4NV=1
TexFlags.TextureShaderNV=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=0

HardwareShaders=0

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=4
Effects=2
ForceShaders1x=0
TypeClouds=1
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0
CockpitMirrorQuality=0
ShowShadowCarrier=0

[DGen]
HistoricalRanks=1
CampaignLength=Medium
NoAirfieldHighlight=1
MaxFLAK=20
AirIntensity=high
GroundIntensity=high
CampaignMissions=normal
CampaignAI=normal
CampaignLength=Short
CampaignDifficulty=Hard
UseAsuraDGen=0
[test]
VisualStaticMethod=0

JacksonsGhost
11-22-2023, 02:51 PM
I'm no tech guru, but I may have found your problem.

You seem to have multiple conflicting lines in your config.ini in the [Render_OpenGL] section.

I think you mentioned in the other thread that you have an Nvidia card. For an Nvidia card I believe you should have the following lines set to "1" in the [Render_OpenGL] section:

TexFlags.TexEnvCombine4NV=1
TexFlags.DepthClampNV=1
TexFlags.TextureShaderNV=1

You do have these lines correctly set to "1" already in your config.ini, but, then you have them repeated at the bottom of the section, but set to "0" in each case, instead of "1".

I suggest you back up your config, then delete those three lines which are repeated and set to "0".

It looks like some of your config may have been copied from a device with a non-Nvidia card. If so, there might be other lines in conflict that I haven't mentioned, but hopefully that's not the case.

I notice that you also have these lines set to "0" in your [Render_DirectX] section, but my config is the same, so I suspect it is normal for these to be "0" in the [Render_DirectX] section when you are running OpenGL.

Let us know how you go with that.

papote
11-23-2023, 07:18 AM
Thanks :) i have the water and the trees now !

I STILL HAD STUTTERS AND THIS IS HOW I FIXED IT :

i went to the NVIDEA control Panel and chAnged 2 settings there:

set my max FPS to 60 (im a 60hz tv :)

I turned off antialiasing FXAA----- this smooth it out
tuning FXAA ON its what was giving me the stutters

thank you for helping me with this IL2 46 ROCKS!